Friday, September 17, 2010

Ptracker v1.1 released

A few days back, Ptracker seemed to have stopped working. The problem, which needed to be fixed was related to the SSL connection with Pivotal Tracker server. Probably something has changed.

This update will fix this problem, and you should be able to see use Ptracker with this new update.

It wasn't a planned release. We had plans of updating the app with new features, but due to this critical problem, wherein, you couldn't even login any more, this needed an immediate fix.

We will be updating the app with new features very soon.


  1. I'm stool having some issues. I'm now getting an error: "SSL Handshake Error. I/O error during system cal, Broken pipe." I've uninstalled after the update and have cleared the application cache. Keep up the work, love the app. Looking forward to the updates.

  2. @T-Reb: This is weird though. It works for me. I will test out this on other devices and check what's wrong. Lookout for the updates on this page.

    Thanks for reporting the issue.

  3. Ok thanks. I'm running the HTC Incredible with (rooted) stock 2.2.

  4. I tried it on a Nexus One, running FRF91 (Android 2.2 Froyo)
    and am running into the same "SSL Handshake Error. I/O error during system cal, Broken pipe." issue.

    This was after a fresh install of the app.

  5. Was the previous release working(on rooted phones)? I am guessing that rooted phones have a separate set of SSL certificates, and thats causing the problem. Anyways, I will be updating the app soon, to conditionally check and apply SSL so that it should work anyway. Thanks for reporting this.

  6. Can anyone confirm if you get similar problem on non-rooted phones?

  7. I have uploaded a fix. Please check and see if it works.


  8. My phone is non-rooted. Still no luck. I'm getting various encryption related toast messages now. I do see the UI, but my project does not load.

    I can try to get more info later (I'm at work now)
    does ptracker write log output somewhere on the phone?

    (I can look at logcat later too, email me if you want some help debugging this. I assume you can see my info through blogger, if not I'll contact you on twitter)

  9. Please try logging out first. If that doesn't work either, the log would be helpful. You can use SendLog to capture the log.


  10. Tried logging out and logging back in. same issue. SendLog doesn't generate anything useful.

    I will email you some logcat output.

  11. I have uploaded a new version, which will log the stack trace. Sorry about that.